Author Topic: Forum maintenance today  (Read 2615 times)

0 Members and 1 Guest are viewing this topic.

Offline PetrifiedWood

  • Friction Fire Fellowship
  • Administrator
  • Belt Grinder
  • ******
  • Posts: 11233
Forum maintenance today
« on: June 27, 2016, 12:36:09 PM »
Today I will be attempting to upgrade the forum software. This may go smoothly, or it may cause a crash. If it causes a crash, I will get the host company to fix it ASAP. You may experience temporary outages.

Offline PetrifiedWood

  • Friction Fire Fellowship
  • Administrator
  • Belt Grinder
  • ******
  • Posts: 11233
Re: Forum maintenance today
« Reply #1 on: June 27, 2016, 01:01:15 PM »
Ok, it looks like the upgrade to the latest forum software worked, but as usual, it broke some functionality. I have contacted the host to get them to address 3 issues I am aware of.

The spell check function, the ads, and an upgrade to the latest version of tapatalk.

They charge for this, but they are usually pretty quick about fixing it.

If there are any other forum functionality issues you are aware of, let me know. I know many of you have had feature requests, but adding new features must come after we fix what we already have.

The issue here is that most of the add-on features were written by 3rd parties. When the main SMF software team writes an upgrade, it sometimes breaks the functionality of the older modifications because they are not required to maintain backwards compatibility with 3rd party modifications.

Offline wolfy

  • Supporting Member
  • Belt Grinder
  • *****
  • Posts: 17581
  • "You want a toe? I can get you a toe." -Sobchak
Re: Forum maintenance today
« Reply #2 on: June 27, 2016, 04:33:02 PM »
Well, that sucks!  :doh:    That means that a lot of the tutorials and instructional posts with links to semi-crucial information will no longer be there and render most of the thread meaningless.......o r am I misinterpreting AGAIN? :shrug:
The only chance you got at a education is listenin' to me talk!
Augustus McCrae.....Texas Ranger      Lonesome Dove, TX

Offline Uncle Sam

  • Mill File+
  • *
  • Posts: 81
Re: Forum maintenance today
« Reply #3 on: June 27, 2016, 06:03:15 PM »
You may be misinterpreting.

It looks like the banner on the main page is gone too. Is that coming back?

Offline PetrifiedWood

  • Friction Fire Fellowship
  • Administrator
  • Belt Grinder
  • ******
  • Posts: 11233
Re: Forum maintenance today
« Reply #4 on: June 27, 2016, 09:42:33 PM »
I still see the banner. The smileys appear to be broken though.

Offline MrFixIt

  • Whetstone +
  • **
  • Posts: 301
  • Old Jarhead
Re: Forum maintenance today
« Reply #5 on: June 28, 2016, 06:44:10 AM »
I don't see the banner either.
Is there a way to change the background color?

Either way, thanks for the work PW!
"I may be goin' to hell in a bucket baby, but at least I'm enjoyin' the ride!"

Offline Sarge

  • Supporting Member
  • Water Stone
  • ***
  • Posts: 2662
Re: Forum maintenance today
« Reply #6 on: June 28, 2016, 08:20:31 AM »
Getting errors on Tapatalk - "bad gateway" and "Tapatalk plug-in on this site is currently unavailable".

Thanks for all you do on this, PW. It's gotta be a big P.I.T.A.
"The man with the knapsack is never lost." Horace Kephart

Offline PetrifiedWood

  • Friction Fire Fellowship
  • Administrator
  • Belt Grinder
  • ******
  • Posts: 11233
Re: Forum maintenance today
« Reply #7 on: June 28, 2016, 11:29:29 AM »
Still working on it.

It appears that one of the problems is the fact we have multiple "themes" installed. Some themes are incompatible with the various modifications. I know some of you have become accustomed to some of the alternate themes we installed, but those were originally installed just as a test. We kept them on as a courtesy to those members who liked them, but it appears that they are causing problems with overall forum functionality and we may have to remove them.

If you are running the default "green bean" theme, things will run smoother. The banner does work on the green bean theme.

The smileys are stored on the server, but after uninstalling the smiley modification they are not linked. I am going to have to poke around and find the path to the smileys and re connect them.

The Tapatalk mod was reinstalled by the hosting service yesterday. I haven't used Tapatalk in a couple of years because their customer service has been completely dismal. The forum software we use is not the most common so Tapatalk support for it isn't as robust as more common software. If it isn't working on your end, please try to resolve the issue through Tapatalk first, before assuming there is a problem with the forum. We have their modification installed and if you are not able to access the forum, then there is something wrong on Tapatalk's end. They will never fix it unless they are pressured into doing so.






Offline Sarge

  • Supporting Member
  • Water Stone
  • ***
  • Posts: 2662
Re: Forum maintenance today
« Reply #8 on: June 28, 2016, 12:46:38 PM »
The Tapatalk mod was reinstalled by the hosting service yesterday. I haven't used Tapatalk in a couple of years because their customer service has been completely dismal. The forum software we use is not the most common so Tapatalk support for it isn't as robust as more common software. If it isn't working on your end, please try to resolve the issue through Tapatalk first, before assuming there is a problem with the forum. We have their modification installed and if you are not able to access the forum, then there is something wrong on Tapatalk's end. They will never fix it unless they are pressured into doing so.
Sounds good. Thanks again!
"The man with the knapsack is never lost." Horace Kephart

Offline PetrifiedWood

  • Friction Fire Fellowship
  • Administrator
  • Belt Grinder
  • ******
  • Posts: 11233
Re: Forum maintenance today
« Reply #9 on: June 28, 2016, 01:03:55 PM »
Ok,I have most of the smileys restored. I dug up an old hard drive from 2012 that had an archived version of the site on it and I was able to find all but a handful of our original emoticons. Those that I couldn't find, I just found some new ones and replaced them. They should be working again as usual. When I uninstalled the smiley set in order to do the upgrade yesterday, it actually removed them from the server, but I was able to use an FTP client to get everything sorted and back where it should be.

I also just checked the spell check function (on a PC using Chrome browser) and it is working for me.

Let me know if tapatalk is still not working and I will try again on my end to see if there is anything that can be done to fix it. The mod is installed and running, but it is an older version since every time we've installed a tapatalk update for the last 3 updates, it breaks the forum. :doh: I have been "letting it ride" so as to avoid the kind of service interruption we have been experiencing yesterday and today.

Offline Unknown

  • Water Stone
  • ***
  • Posts: 2720
  • Alcholocost of Gibberish
Re: Forum maintenance today
« Reply #10 on: June 28, 2016, 04:05:43 PM »
Wow that sounds like- not fun-
We all appreciate the effort.  Thanks PW

Offline wolfy

  • Supporting Member
  • Belt Grinder
  • *****
  • Posts: 17581
  • "You want a toe? I can get you a toe." -Sobchak
Re: Forum maintenance today
« Reply #11 on: June 28, 2016, 04:18:22 PM »
YES.......THANK you for going to all this trouble to unsnarl the kinks!   I am still running under the old 'cement' colored version because the the 'green bean' version appears in a small-print column that shows up on the left hand 25% of the screen.  NOT FUN & NOT WOLFY APPROVED! :doh:

Everything has been functioning perfectly for me.......except for a temporarily non-functional  :chopwood: but even he's back splitting wood for the campfire again. :banana:
The only chance you got at a education is listenin' to me talk!
Augustus McCrae.....Texas Ranger      Lonesome Dove, TX

Offline Unknown

  • Water Stone
  • ***
  • Posts: 2720
  • Alcholocost of Gibberish
Re: Forum maintenance today
« Reply #12 on: June 28, 2016, 04:59:52 PM »
Just realized The B&B banner is still not showing on this tablet, will check pic later,

Anybody else missing that?

Offline wolfy

  • Supporting Member
  • Belt Grinder
  • *****
  • Posts: 17581
  • "You want a toe? I can get you a toe." -Sobchak
Re: Forum maintenance today
« Reply #13 on: June 28, 2016, 05:30:46 PM »
I never had a banner......we 'cement' users don't need no steenkin' banners. :popcorn:

Hey......I just noticed the little :green guy: that used to be the last one in the lineup is MIA!  :'(
The only chance you got at a education is listenin' to me talk!
Augustus McCrae.....Texas Ranger      Lonesome Dove, TX

Offline PetrifiedWood

  • Friction Fire Fellowship
  • Administrator
  • Belt Grinder
  • ******
  • Posts: 11233
Re: Forum maintenance today
« Reply #14 on: June 28, 2016, 05:48:08 PM »
I never had a banner......we 'cement' users don't need no steenkin' banners. :popcorn:

Hey......I just noticed the little :green guy: that used to be the last one in the lineup is MIA!  :'(

Yeah, he was the "blah" emoticon. I couldn't find one that was close enough to use to replace him.

The banners are theme dependent. Some themes are incompatible with them.

Offline wolfy

  • Supporting Member
  • Belt Grinder
  • *****
  • Posts: 17581
  • "You want a toe? I can get you a toe." -Sobchak
Re: Forum maintenance today
« Reply #15 on: June 28, 2016, 06:04:46 PM »
Well, crap!  >:(     I'll miss his expression.......AN D complexion. ;D
The only chance you got at a education is listenin' to me talk!
Augustus McCrae.....Texas Ranger      Lonesome Dove, TX

Offline Aven

  • Whetstone +
  • **
  • Posts: 542
  • Woods Woman
Re: Forum maintenance today
« Reply #16 on: June 28, 2016, 07:30:11 PM »
PW that sounds like a whole lot of not fun.  Sorry you had to go through it.  Much appreciate you doing it.  I need my virtual campfire for my sanity's sake.
Seriously people, stop expecting normal from me.... We all know it's never gonna happen.

Offline Yellowyak

  • Water Stone
  • ***
  • Posts: 1962
Re: Forum maintenance today
« Reply #17 on: June 28, 2016, 07:56:11 PM »
Thanks for all of the hard work PW, we all appreciate it.

Offline Dano

  • Water Stone
  • ***
  • Posts: 4972
Re: Forum maintenance today
« Reply #18 on: June 28, 2016, 08:12:19 PM »
I've noticed that even though I'm using the green bean theme, when I first navigate to the site, the theme is probably cement with no banner.  As soon as I log in, it changes back to green bean and then the banner is there.

No biggie, just thought I'd mention it for what it's worth.

And I agree, thank you for all your hard work on this!!!!

Offline PetrifiedWood

  • Friction Fire Fellowship
  • Administrator
  • Belt Grinder
  • ******
  • Posts: 11233
Re: Forum maintenance today
« Reply #19 on: June 29, 2016, 12:52:32 AM »
Thanks for the support everyone!

Dano, I will have to check and see if green bean is set as default. That might be why it shows up when you first land on it. Or it could be a cookie thing.

You could try refreshing your browser when you see the concrete theme and that might fix it. If not it is something on the forum end.

Just to add, I checked and I did need to set the forum default to green bean. So perhaps that will fix it. When I log out all I see is green bean.